Changes between Version 44 and Version 45 of DeveloperGuidelines/Eclipse


Ignore:
Timestamp:
11/10/11 06:15:48 (10 years ago)
Author:
Peter Banka
Comment:

--

Legend:

Unmodified
Added
Removed
Modified
  • DeveloperGuidelines/Eclipse

    v44 v45  
    2525== Configuration ==
    2626 1. Set up the Python Interpreter:
    27   i. Window > Preferences > !PyDev > Interpreter - Python
    28   i. New, Browse to python26/python.exe (or python27/python.exe if using 2.7), OK, OK
    29  2. Add a new !PyDev Project:
    30   i. File > New > Project > !PyDev Project > Next
    31   i. untick Use Default
    32   i. Browse to the web2py directory
    33   i. Give the project a name, e.g.: "web2py", Next
    34   i. untick "Create default 'src' folder and add it to the pythonpath"
    35  3. Debug Configuration: Run > Debug Configurations > Python Run
    36   i. Name: Enter a name, e.g. web2py or eden.
    37   i. Project: Browse to web2py
    38   i. Main Module: Browse to web2py.py
    39   i. Arguments tab: Program Arguments: -a password (Choose a password for web2py and substitute it for "password".)
    40   i. Apply, Debug
    41   i. If asked, unblock in Windows Firewall
    42  4. If you want a HTML and JS editor (with syntax highlighting) in Eclipse:
    43   i. Help menu > Install New Software
    44   i. Work with: http://download.eclipse.org/releases/helios
    45   i. Add, OK
    46   i. Select {{{Web, XML and Java EE Development}}}
    47   i. (If present) select {{{Web Tool Platform}}}
    48   i. (If you get a conflicting dependency error, deselect the problem tool.)
    49   i. Tick to trust certificate, Restart now
     27  i. Window > Preferences > !PyDev > Interpreter - Python. Click New
     28     i. On Windows: Browse to python26/python.exe (or python27/python.exe if using 2.7), OK, OK
     29     i. On Linux: "python" is the name of the interpreter, the location is "/usr/bin/python", OK, OK
     30 1. Add a new !PyDev Project:
     31  i. File > New > Project...
     32  i. Open the !PyDev folder, and choose !PyDev Project
     33  i. Give the project a name "web2py"
     34  i. Un-tick "Use Default"
     35  i. Grammar Version (should be 2.6 in the Linux VM)
     36  i. Browse to the web2py directory (on the Linux VM, this is in /home/web2py)
     37  i. Un-tick "Create default 'src' folder and add it to the pythonpath"
     38  i. Click Finish
     39  i. Click "No" when asked to open the perspective
     40 1. Debug Configuration:
     41  i. From the Run menu, choose Debug Configurations...
     42  i. Double-click Python Run
     43  i. Enter a name "web2py"
     44  i. Project: Browse to web2py (on the Linux VM, this is '/home/web2py')
     45  i. On the Main tab: Browse to web2py.py (on the Linux VM, this is '/home/web2py/web2py.py')
     46  i. On the Arguments tab: Type in the program arguments: "-a password" (Choose a password for web2py and substitute it for "password".)
     47  i. Click Apply
     48  i. Click Debug
     49  i. On Windows: If asked, unblock in Windows Firewall (not necessary on the Linux VM)
    5050
    51  6. Miscellaneous suggestions:
     51 1. Miscellaneous suggestions:
    5252  i. Right-click on Java perspective in top-right & select Close
    5353  i. Window > Open Perspective > Other > Debug
    5454  i. Window > Show View > Expressions
    55   i. Right-click on toolbar > Customise Perspective > Go through the tabs and untick !PyDev Debug, Run, and External Tools
    56   i. Window > Preferences > General > Editors > File Associations > *.html
    57    * If Text Editor is not in the list of associated editors: Add (lower one), Text Editor, OK.
    58    * Select Text Editor, click default, OK.
    59    * Select Web Page Editor, remove, OK.
    60    * Select Web Browser, remove, OK.
     55  i. Window > Customize Perspective > Go through the tabs and untick !PyDev Debug. Click OK
     56  i. Set your default HTML editor
     57     1. From the Window menu, choose Preferences
     58     1. Under General section on the left
     59     1. Open the Editors section
     60     1. Choose File Associations
     61     1. Highlight .htm
     62     1. Click "Add..."
     63     1. Choose "Text Editor"
     64     1. Click OK
     65     1. Repeat the process with .html
     66     1. Click OK
    6167  i. Window > Preferences > General > Editors > Text Editors
    6268   * tick Show line numbers