wiki:SysAdmin/Pootle

Version 6 (modified by Fran Boon, 8 years ago) ( diff )

--

Pootle

Pootle is used to allow translators to collaborate on both doing the initial translation & refining it once 'completed'.

Installation

http://docs.translatehouse.org/projects/pootle/en/stable-2.5.0/server/installation.html

Assuming a base Debian stable (6.x):

apt-get install -y libapache2-mod-wsgi
apt-get install -y mysql-server python-mysqldb phpmyadmin mytop
apt-get install -y python-setuptools
# memcached
wget ftp://ftp.tummy.com/pub/python-memcached/python-memcached-latest.tar.gz
tar zxvf python-memcached-1.51.tar.gz
cd python-memcached-1.51
python setup.py install
cd ..

Usage

See UserGuidelines/Localisation#A.UsingPootle

Maintenance

When adding languages, use this resource to configure them properly:

The script that Fran used to use to update files between Bzr & Pootle is:

If the script fails, check for the presence of a ` in a T("") - this causes the languages.py to reset the languages/* to default &/or stop web2py2po from working!

ToDo

Attachments (6)

Download all attachments as: .zip

Note: See TracWiki for help on using the wiki.